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OpenOffice.org Writer

Introduction
 

Writer is an OpenOffice.org word processing module which helps users to create all sorts of 
professional written documents like reports, newsletters, personal and formal letters etc. It 
also allows easy integration of charts, pictures, designs using styles and also have features 
like Spell checking, thesaurus, hyphenation, auto-correct, find and replace, automatic 
generation of tables of contents and indexes and mail merge.

 To get started with Writer:

Go to Application > Office > OpenOffice.org writer.
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Writer interface

Menus

The Main menu item is a collection of related commands from which users can make a 
selection and they are located across the top of the Writer window. Whenever a menu is 
clicked, it displays a long list of related options. The main menu selections are File, Edit, 
View, Insert, Format, Table, Tools, Window and Help.

● File: it contains commands to Open, Save, New, Export as PDF etc that applies to the 
whole document.

● Edit: It contains the commands to edit the documents like Undo, Find and Replace 
etc. 

● View: it controls the display of document, by using commands like Zoom, Web Layout 
etc.

● Insert: Inserting elements into the document using commands like headers, footers 
and pictures.

● Format: Formatting the layout of document using commands like Styles and 
Formatting, Paragraphs, Bullets and Numberings etc.

● Table: Insert and Edit a table in a text document by using the commands given in it.
● Tools: It contains functions like Spell check, Custom, and Options.
● Window: it's used to display window.
● Help: It contains Help, information about the program etc.

Standard Toolbar

It's located just below the menu bar and provides quick access to the frequently used editing 
functions. For instance, to save a document you just click to the floppy disk icon on the tool 
bar.

Formatting Toolbar

It's located just below the Standard toolbar and provides quick access to the most frequently 
used formatting functions. For example, aligning the texts, managing the font-size of the 
texts, assigning colors to the text etc.
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Scrollbars
The scroll bars are used to move the view of the document. The two bars are vertical scroll 
bar which is located along the right side of the window and the horizontal scroll bar located 
along the lower portion of the window, just above the status bar.

Status bar

This bar displays the explanations of the currently selected text at the bottom edge of the 
program window.

Minimize button
It appears as a button with a small horizontal line located in the group of three 
buttons(upper-right corner) and it's used to reduce the window size.

Maximize/Restore button
This button switches back and forth or toggles between displaying a window in it's maximum 
size and restoring back to it's previous size.

Close button
It closes the current window or an application.

Screen Tip
It's a help item which shows the name of a button or screen element when you rest the 
mouse pointer on the toolbar button or screen element. For instance, when you position the 
mouse pointer over the Save button, a small yellow Screen Tip appears displaying the word 
Save.

 

Creating a New Document

There are four ways to create a new document: 
 Go to File > New > Text Document, or press Ctrl + N (shortcut).
 Click New button on the toolbar.
 Go to File > New > Templates and Documents  to make sure that all 

document have similar page layout.
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Entering Text
Whenever you enter text to create a document, you don't have to hit Enter at the end of 
each line because the Writer Wrap automatically wraps texts from one line to the next each 
time the insertion point reaches the right margin. Press Enter only when you want to begin a 
new paragraph or insert a blank line.

Press Backspace to delete characters to the left of the insertion point and hit Delete to 
delete the characters to the right of the insertion point.

Editing a Document
With Writer, users can quickly and efficiently edit letters, documents, newsletters, memos, 
reports etc. The red wavy line indicates misspelled or unknown words and the green wavy 
line indicates incorrect or questionable grammar usage.

Firstly identify the texts, line, paragraph, sentence or the entire document you want to 
edit/change and select the texts by using the shortcuts. After selection of the desired texts, 
then start editing and once you are done with editing, save the file.

Inserting Text in a Document
To insert text in a document, the Writer provides two modes:

  Insert Mode
 Overtype Mode

Insert mode is a Writer's default mode and used to start a program. In this mode, the 
existing text will move to the right as you type in new text.

In Overtype mode, the existing text is deleted and replaced by the new text you type, 
including spaces.
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Opening an Existent Document
To reopen a document after saving it, to review it's content or make changes, navigate to the 
folder that contains the document ans open it.

   You can open an existing document by:
1. Going to File > Open, or Ctrl+O .
2. Choose the file type. 
3. Then select file you are looking for and Open it.

To Save a Document

Three ways to save a document:

1. Press Ctrl+S
2. Select File > Save
3. Click Save button on the main toolbar.

 

To automatically save the document at regular interval, configure by:

1. Select Tools > Options, as Option window appears
2. Click Load/Save > General.
3. Click Autosave everytime, to enable box to set the interval which is 15 minutues by 

default. To set it other values, type the value or press up and down arrow keys.
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To Save as Microsoft Word Documents

To share the document with people who don't use openoffice.org, but use Microsoft word,

1. First Save the document in OpenOffice.org's format(.odt).
2. Click File > Save As, Save as Menu appears.
3. Select the Word format you want, from the drop-down menu
4. Click Save.

Working With Texts

Selecting Text 

To select the desired text for editing, first select the first piece of text, hold down the control 
key and hold mouse to select next text. Repeat as u need and with the selected text, you can 
delete it, change it, rename it,etc. You can  also deselect text by clicking anywhere within the 
document window. The selected text will appear highlight with black background and white 
text. You can even use Shift+Arrow keys to select the texts. There are various methods to 
select blocks of text:
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To Select Do this

One word Double-click on that word

A line Click the selection area to the left of the line

A sentence Hold down the Ctrl key and click anywhere in 
the sentence.

A paragraph Double-click the selection area to the left of 
any line in the paragraph, or triple-click 
anywhere in the paragraph.

An entire document Hold down the Ctrl key and click anywhere in 
the selection area, or triple-click anywhere in 
the selection area.

 Copy: To copy selected text to another document by using Edit >Copy,   Ctrl+C, or 
click to Copy icon on the main toolbar.

 Cut: To cut a selected text to remove or paste into another document by Edit > Cut, 
Ctrl+X, or click Cut icon on the main toolbar.

 Paste: To paste a selected text after copying or cutting into another document by 
using Edit > Paste, Ctrl+V, or click Paste icon on the main toolbar.

 Delete: To delete characters either by hitting Backspace (if deleting on left), 
Delete(if deleting on right side).And to delete selected texts with mouse by Right-
click > Delete.

 Moving a paragraphs quickly: Put cursor on any paragraph, Press Ctrl+Alt along 
with up or down arrow.

Finding and Replacing Specific Text
To find and replace words in a long document is tedious and inefficient. So, Writer has Find 
and Replace feature which will automatically find the text inside a document and also replace 
the document with another. The Find & Replace dialog box will locate the word or a phrase in 
a long document and replace it with a different words or phrase. You can even click More 
Option button to set additional search option. It helps the user to review or edit text in a long 
document by moving quickly to a particular location. To find and replace text within the 
current document:

I.  Click Edit > Find & Replace or Ctrl+F, the Find & Replace dialog box 
pops out.
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II. Enter the text you want to find in the search field.
III. Type a new text you want to replace in the Replace field.
IV. Select various options given like matching the case, matching the whole 

document, matching the whole words or search for similar words etc.
V. Then click Find to find the text, and then click Replace to replace the 

new word.
VI. Find All and Replace All will,first select all instances of the search text in 

the document and  later replace all matches.

Undo & Redo

1. To Undo an actions/changes, press Ctrl+Z, or click Undo icon, or click 
Edit > Undo.

2. To restore an actions/changes, press Ctrl+Y, or click Redo icon, or click 
Edit > Redo.
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Numbering and Bullets

We have numbering and bullets icons on and off on the toolbar, to create bulleted and 
numbered list in the document.

Numbering: Click Tools > Line Numbering and select Show Numbering checkbox on 
top of the left corner and click OK.

How to insert notes

I. Click Insert > Notes by placing the cursor on the text you want to comment.
II. Type your note in Insert Note dialog and click Author button to insert initials and date 

and time.

How to insert footnote and endnote
The footnotes refers to extra information about the topic at the bottom of a page, and 
Endnotes refers to information at the end of the document and they are automatically 
numbered.

You can directly insert footnotes by clicking Insert Footnote Directly icon on Insert 
toolbar.

1. Put the cursor on the document where you want to place the anchor of 
the note .

2. Select Insert > Footnote
3. Select the format you want to use from the Numbering area. For 

instance, if you choose Character, then click browse button and select 
the character you want to use for the footnote. 

4. Select either Footnote or Endnote in the Type field and click Ok.
5. Type your note.You can also format the settings of Endnotes and 

Footnotes by selecting  Tools > Footnotes.

Inserting Special Characters

Special Characters are symbols and punctuation marks that do not have a key on most 
keyboards. For example, an em dash(__), a copyright(©), a trademark(™), an ellipsis(...) etc.
To use them:

1. Place the cursor on the document where you want to insert the special 
characters.

2. Select Insert > Special Characters, and it will open up a dialog box 
containing all the special characters.

3. Choose Characters orderly that are to be inserted, and click OK.
4. The selected characters will have numerical codes and displayed on 

lower right.
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Headers and Footers
A header is the text that appears at the top of the page which includes title of the work, date, 
topics, titles, chapter headings and page numbers. Footer is a text printed at the bottom of 
the page that includes date, author's name and title of the document. we can also add texts, 
graphics whereby the following pages will use the same style that you add.The header and 
footer can be used on a document with multiple pages, and it helps the reader to locate 
where they are in the document and which section are they reading. To add header & footer 
in a document:

1. Select Insert > Header, and Insert > Footer .

2. Select page style for the current page menu from the submenu, for 
both header and footer.

Tab

Tabs are used to indent the first line of the paragraph or align text or numbers in columns.

How to Insert Different Field in a Document

Fields like date, time, page number, page count etc can be inserted by:

I. First, placing the cursor in the document where you want to insert the 
field.

II. Select Insert > Field, and choose the field you want to insert.
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Creating a Folder
A folder is a storage area on your computer's hard disk or a network drive. Users create 
folders to store files by projects, author, file type etc.

In Writer, you can create folder easily and save it with different names in the Save As dialog 
box. It's also easy to organize, locate and create folders with the Writer's file management 
features. 

Using Templates and Wizards

A Template is a document containing built-in text, styles and other formatting which are 
used to create other documents that shares the same basic formatting. It determines the 
basic properties of a document like the margins and layout, characteristics of the text such 
as it's font's size and style etc. The Normal template is the default generic template.
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How to Use a Ready-Made Template

1. Go to File > New > Templates and Documents, a Templates and Document 
dialog box appears.

2. Select New Document to create your own template or click Templates to use 
the formatted document.

3. Then start replacing the placeholder text with your text and save.

A Wizard is also used to create a document that prompts you for information one step at a 
time and then generates a formatted document based on your answer. It's used to create 
memos, faxes and other bussiness documents with much less placeholder text than that of 
template and also walks you through text entry for many parts of a document whereas 
template simply displays placeholder text in which you replace it with your own text.

To get started:

1. Go to the File > Wizards > Letter, a Letter wizard dialog box appears 
in which you should specify the type of letter you want such as Business 
letter, Personal letter, Formal letter etc.

2. Then select the Items to be printed in the letter template and choose the 
Name and Location. Then Save it.
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Formatting Text

Formatting toolbar is the quickest and easiest way to change the appearance and the 
attributes of the text in several different ways. Some of the formatting options are:

1. Font List, which has list of available fonts in it.
2. Font Size drop-down list which has list of differents font sizes.
3. The attribute buttons like Bold, Italic, Underlining, lowercasing, text-

colors etc.

Applying Character Effects to Text

To apply formatting effects like superscripts,subscripts,strikethrough and small caps 
character effects which are not available on the Formatting tool bar, do Right-click and 
select Style.

Print Preview

This Print Preview window show you how the lines on the page will appear when after printing 
and where page break occurs. It also allows you to make necessary changes and adjustment 
on the page, if you don't like the layout before you print. It helps you to identify the desired 
formatting changes without wasting paper.
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1. Click File > Page Preview or Click Page Preview button.
2. Click Book Preview icon to display right and left pages in their correct 

orientation.
3. Click Print page view icon, to print document in this page view.

Printing a Document
1. Click Print icon on the main toolbar, to print one copy of all pages in the 

current documentusing default printer.
2. Click File > Print,to print multiple copies of the document, print from 

different printer, print selected text, or print a range of pages by 
specifying the options in the Print dialog box.
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Exporting to PDF (Portable Document Format)

It's a industry-standard file format, used to represent a document in a 2-D format using 
Acrobat reader or other PDF readers.

1. Click PDF icon in the main toolbar, to export entire document using default PDF 
settings and enter filename and location for PDF file, but you cannot choose 
page range or print quality.

2. Click File > Export as PDF, to have control over the content and quality of 
PDF(by having options like pages to include in PDF, compression type used for 
images etc ).
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Page Settings

We can customize a document by changing the text  appearance, altering page margin, 
resetting paragraph alignment, changing tab settings, creating headers and footers etc.

Page Margin: it's the amount of space at the top, bottom or sides surrounding the text on a 
page.

Indent & Spacing:  It  determines the alignment of a paragraph in relation to the page 
margin setting and spacing indicates the area above and below the paragraph and space 
between the lines.
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Click Format > Page > Page tab, to open a Page setup dialog box and determine the 
appearance of it on the printed page, by setting the margin, Paper and the Layout.
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Formatting a Paragraph 

A paragraph is defined as any amount of text that ends with a hard return. To format a 
paragraph, select Format > Paragraph and open a Paragraph dialog box, in which you will 
set the formatting to apply for the desired text. 

By default, the paragraphs are set to be single-spaced and left-aligned with no indentation. 
The formatting selected for a paragraph will be also applied to the next paragraph that you 
type because all formatting associated with a paragraph is stored in the paragraph mark.

Inserting a Page Number
Page numbers are used in a document having more than one page, to mark each page. It's 
used because it has lots of advantages like:

➢ Make the document more readable and user-friendly when presenting the 
document to other people.

➢ It helps to keep the lengthy documents in good order, especially when 
editing or printing random pages from the document.

➢ It also reminds you of where you are in the document.

 To insert page numbers in a document, click Insert > Fields > Page Number.
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Editing & Proofing Tools

Checking Spelling in a document

Spell checker is a part of proofreading which will check the spelling of a document and 
correct it. Three ways to check the spellings in a document are:

1. Go to Tools > Spellcheck or simply press F7.
2. Press the Spellcheck icon or Auto-Spellcheck icon on the standard 

toolbar.
3. Right-click on the word having red-wavy underline, and assign the 

suggested correction from the list.

Using Shortcut Menus for Words and Phrases
To get rid of text with Green-Wavy Underline(grammatical error), just right-click over it and 
make a desired selection of the text. And for word with Red-Wavy Underline, right-click on the 
word and select Add to Dictionary. 
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Inserting Date and Time
You can insert date and time in numerous formats like text or a field, into a document and 
once inserted, it will be updated automatically when a particular action is performed like 
opening, saving or printing a document. The date and time is inserted within the footers of 
the document. To insert:

1. Go to Insert > Footer, to open a footer.
2. Click on Insert > Fields > Date or Time.

Inserting a Picture From a File

A picture is any graphical image that is created by another program, captured from a scanner 
or a digital camera, or downloaded from the web. To make the document visually interesting 
for the readers, we insert pictures like drawings, photographs, clip arts and other graphics 
into the text document. You can insert them easily at the he location of the insertion point, 
from a picture file stored on your hard disk. To insert:

1. Go to Insert > Pictures > from File, which will open a Insert Picture 
dialog box.

2. Browse to the folder that contains pictures and select the desired picture 
to be inserted.

3. After inserting, Save the document.
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Text wrapping styles are also available.

Tables

A table is a structure made up of a rectangular boxes called cells, arranged in rows and 
columns. 

A cell is an intersection of rows and columns, that are used to store and format text, numeric 
values, and graphics etc.

A column is a vertical arangement of text or numbers in a table.

A row is a horizontal arrangement of text or numbers in a table.

Table provides a convenient way to group ,organize and format similar data and also provides 
variety of techniques to create and format table. We can also modify the structure of a table 
by combining cells, inserting and deleting columns or rows, resizing rows and columns etc.
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How to insert Tables

I. Put  the cursor where you want to place the table in the document.
II. Click Insert > Table or Click the Table icon on the standard toolbar or simply 

press F12.
III. An Insert Table dialog box appears, in which you should specify the no. of rows 

and columns required.

Table toolbar

To Delete Tables

I. Select from end of paragraph,before table begins, till the start of the next 
paragraph after the table ends

II. Hit the Delete or Backspace tab or go to Table > Delete > Table.
III. To delete rows, go to Table > Delete > Rows.
IV. To Delete columns, go to Table > Delete > Coulmn.

To Merge Table Cells
Merging cells is the process of joining multiple cells into one larger cell. You can either merge 
multiple cells in a row or column into a single cell. To do these merging task:
Go to the Table > Merge cells, to merge cells and to merge table, select Merge Table.
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Name Address

General Properties of a Table

Click Table > Table properties, by placing cursor on the table.

Help

 Go to Help > OpenOffice.org Help
 Press F1.

Closing a Document

 Click File > Close
 Click Close icon on the document window.

Closing a Writer

To close a document completely, click File > Exit or Ctrl+Q. 
If the document is saved, it will close otherwise a warning window will appear asking to save 
it or discard changes.
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OpenOffice.org Calc

Openoffice.org Calc is a powerful tool replacing Microsoft Excel in Debian Linux, for 
professional functions like financial, statistical and database functions and lot more. It's used 
almost in every profession to calculate, graph, analyze and store information. Spreadsheet 
are primarily used to work with numbers much like Writer is used to work with text. The 
important functions and capabilities of Calc are:

 Calculating: Calc is a spreadsheet program and it contains cells into which we can 
enter texts, digits, formula to calculate simple and complex result.

 Arranging Data: In Calc, data can be organized in such a way that it's easy to read, 
reorganize to show or hide data ranges,  format ranges depending on special 
conditions, or calculate total and subtotals.

Open a Spreadsheet
To open a spreadsheet, go to Application > Openoffice.org Calc or if you are in a Writer, 
then you can open by clicking File > New >Spreadsheet and a spreadsheet appears on 
our screen.

25



Identifying Basic Part of OpenOffice.org Calc

Main Menu Toolbar
The Main menu toolbar gives you access to many basic commands used in calc. 

Function Toolbar
The Function toolbar contains icons that provides quick access to command like New, Open, 
Print, Copy, Paste etc.

Formatting Toolbar
The Formatting toolbar consist of icons and drop-down menus which allows you to select a 
font, font alignment, font color, number formats, border options, background colors etc to 
format your document.

Formula Toolbar
The Formula toolbar contains Name Box drop-down menu(displaying the cell name )and a 
long white box called Input Line(displays the formulae). 

Cells
A cell is a fundamental element of a worksheet in which things are added and seen. The Cell 
Address is a combination of column letter followed by a row number(eg. A4, B7, C21 etc) to 
identify the location of a cell in a spreadsheet.
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Rows and Columns
Each cells in the spreadsheet are referred by rows and columns, and these rows and columns 
are  numbered from 1 to 32000 and  designated with letters from A to Z, AA to AZ and so 
on respectively. For instance, A1 is the first cell in the upper-left corner of the sheet and last 
column is labelled with letters IV.

Row headers contains Row number and column header contains Column name.

 To select whole set of rows or columns, click on one of these headers 
 To select Whole sheet, click on the unlabelled button at the intersection of rows and 

columns headers at the top left.

The texts when typed in a cell A1, it also appears in the Input line of formula bar and you will 
notice that more texts added can fit in the cell. Any cell can accommodate text longer than a 
cell. If cell to the right is not empty, then there will be a small triangle on right- hand edge of 
first cell indicating that the cell contains more texts than it displays.

Try to increase the width of column, if number cannot be displayed in a cell due to formatting 
or lengthy texts etc.

Values and formula
The cells contains contents like texts, formulas, numbers, dates etc which can are easily 
specified or modified and updated by recalculating formulas with current data. The values 
can be emphasized by highlighting value from View menu.

Entering Data
1. Click on A1 cell (A is the first column in Row 1)& you will see a black border around A1 

cell indicating that cell A1 has been selected/active cell.
2. Type Hello World & Press Enter. Then you will see that the next active cell is A2.

Formatting a Spreadsheet
The cells in the spreadsheet are mostly used after formatting their borders, colors, text 
numbers and other attributes. We can format either by using predefined formats or creating 
numbers format. For cells, there's a wide selection of cell Styles.

Formatting Numbers
It will display the numbers in it's default format, with two decimal places after rounding it off. 
For instance, 1234.5678 will be displayed as 1234.57.

I. Put the cursor at the number and choose Format > Cells to open Cell 
Attributes Dialog.
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II. The Number tab consist of selection of various predefined number format and 
the preview box at the bottom right of dialog box, shows how the current 
number will appear with a particular format.

III. The dialog also allows defining attributes like font, size, color etc on Front tab 
page, which will be applied to selected cells or cell's content.

You can also modifying number of decimal places, font and it's effects, alignment, borders, 
background of the cells.

Delete Data
1. To delete a data, select the cell you want to delete( eg. A1) & press Delete key.
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Spreadsheet Math

Calculating in a Spreadsheet
These are the important steps to work with spreadsheet: creating and entering formula, 
entering data(texts and numbers), obtaining results, modifying source data or formula and 
how to see the result of newly data and formulas.

➢ Addition
          For Addition, + sign is used and to enter it, Press Shift key with += key.

1. Enter 10 in cell A1 and press Enter key which will activate the next 
cell A2.

2. Enter 10 in cell A2 and press Enter key to activate the next cell A3.
3. Enter 10 in cell A3 and press Enter to activate the next cell A4.
4. Enter 10 in cell A4 and press Enter to activate cell A5.
5. Click A5 to add the column of numbers.

6. Click on the Sum on the Formula toolbar, and the (=) icon changes to 
Accept icon.

7. Click on the Accept icon to display the Formula=SUM(A1:A4), in the 
A5 cell. The A1:A4 in the parenthesis is called Cell Range and 
indicates shorthand for “from A1 to A4” and the separator character 
between the parameters is a Semi-Colon(;)  . 
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8. Press Enter to see the result i.e the Sum of the Numbers.

➢ Subtraction
                For subtraction, - sign is used, to get it Press - key.

1. Click on A1 and enter 10. Then press Enter key to activate the next cell 
A2.

2. Enter 5 in A2, and press Enter to activate the next cell A3.
3. Type =A1-A2 (Or Click = function which appears in A3 and will change 

to Accept icon(a Green Tick mark), there you type “A1-A2”.
4. Press Enter to see the Difference/Answer, 5 in the cell A3.

➢ Multiplication
                For multiplication, * sign is used and to enter it, Press Shift key and number 8 key.

1. Click in A1 and enter number 5, and press Enter.
2. The cell A2 get activated and enter 10.
3. To multiply, type =A1*A2 ( Or click function = which appears in A3, and 

when function = changes to Accept icon, then type  “A1*A2” ).
4. Press Enter to view the Product/Answer, 50 in the cell A3.

➢ Division
           For Division, slash (/) sign is being used and to enter it, Press ? key [ ? and / ].

1. Click in A1 and enter the number 20 in it.
2. Then enter 2 in the cell A2 and press Enter.
3. Type =A1/A2( Or click the function = which appears in the cell A3 and 

when the function = changes to Accept icon, type  “A1/A2 ”).
4. Press Enter to see the Quotient/Answer of A1/A2.

➢ Exponentiation
           For exponential expression, ̂  sign is used. To enter it, press Shift key with number 6 
key. For instance, the number 102  is written as 10^2.

1. Click A4 and enter 10 in it.
2. Then Enter 2 in A5 and press Enter.
3. Type =A4^A5 ( Or click function = which appears in the cell A6 and 

when the function = changes to Accept icon, type “A4^A5”).
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4. Press Enter to see the answer, 100 in cell A6.

➢ Enter Formulas
    While entering formula, the order of the operation must be correct. The order is 
Exponentiation, Division, Addition, then Subtraction. For instance, let's calculate the 
equation:              
                                A+10 
                                B+20

1. Type 20 in A1 and press Tab to activate the next cell B1.
2. Type  10 in B1 and press Tab to activate cell C1.
3. Type the formula =A1+10/B1+20 ( Or click function = which changes to 

Accept icon and type the formula “A1+10/B1+20”).
4. Press Enter or Click Accept icon to see the answer,41 in cell C1.

 
You need to use parenthesis when you use formulas with equations in numerator and 
denominator to calculate properly and correctly

1. Click on C1 and click on the Input Line.
2. Edit the formula to read =(A1+10)/(B1+20).
3. Click the Accept icon to see the correct answer, 1 in the cell C1.

➢ Calculating with Formula
Formula starts with equals to (=) followed by numbers, texts, or other data and also 
contains arithmetic operators, logic operators or function starts. some of the Calc formula 
are:

Formula Meaning

=A1+10 Displays the contents of cell A1 plus 10.

=A1*16% Displays 16% of the contents of A1.

=A1 * A2 Displays the result of the multiplication of A1 and A2.

=ROUND(A1;1) Rounds the contents in cell A1  to one decimal place.

=EFFECTIVE(5%;12) Calculates the effective interest at 5% annually with 12 
payments.

=B8-SUM(B10:B14) Calculates the sum of the cells B10 to B14 minus the value 
of B8.

=SUM(B8;SUM(B10:B14)) Calculates the sum of cells B10 to B14 and adds the value 
to B8.

31



Copy Formulas
To copy a formula, so that the formula itself is copied:

1. Select the cell that is to be copied.
2. Right-click & select Copy to copy the material.
3. Select the Cell where the material is to be displayed.
4. Right-click and Paste the material on that cell.

 
To copy the answer of a formula

1. Select the cell that contains the formula.
2. Right-click and click Copy to copy the material to the clipboard.
3. Select the cell where the material is to appear.
4. Right-click and click Paste-Special, in which a Paste Special Window 

appears.
5. Remove the check marks at Paste All and Formulas.
6. Add a check mark at Numbers and click OK.

Sorting Data
1. Enter numbers in cells A1 to A10.
2. Click Data > Sort.
3. In sort criteria tab, Select sort by column A and ascending.
4. Click Ok.
5. The random numbers will be sorted in ascending order.

DATES

Formatting Dates
To format the date and time as desired by the users,go to Tools > Options > 
Openoffice.org > General. 
Here General defines up to which year a two-digit xx will should be displayed as 20xx. 
For instance, if 1/1/30 or higher is entered, it will be internally treated as 1/1/1930 or higher 
but all lower years applies to next century i.e  if 1/1/20 is entered, it will be converted to 
1/1/2020.
Externally, year date is defined as two digits whereas internally it's managed as four digits by 
OpenOffice.org.

Calculating Dates and Times
Users can display and calculate dates and time, like finding out the exact one's age in second 
or hours by following the steps:

I. Open new spreadsheet
II. Enter a date ( eg. birthday) 1/3/84 in cell A1.
III. Enter formula: “=NOW() - A1”  in cell A3.
IV. Press Enter or Accept icon on the formula bar() to see result in the date format.
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V. Right-click this cell to see the difference between two dates as a no. of days, and the 
format of A3 should be set as a number.

VI. Select Format cells, and a Cell Attributes Dialog appears.

■ The Number category will be highlighted on the Numbers tab and the format is 
set to General that will display the result of date entries calculation as a date.

■ Set number format to -1, 234 for example.
■ Click Ok to close the dialog.

VII.Cell A3 will contain the no. of days between today's date and the specified date.

VIII.Experiment with some additional formulae.

■ Enter A3 * 24 in A4 to calculate hours.
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■ Enter A4 * 60 in A5 to calculate minutes.

■ Enter A5 * 60 in A6 to calculate seconds.

■ Press Enter after every formula.

Columns

Add a Label to Columns

1. Click cell A1 to make it active and press Tab to make the next cell B1 
active.

2. Type Serial No, & press Tab key to actiavte cell C1.
3. Type Item Name and press Tab key to activate cell D1.
4. Type Quantity and press Tab to activate cell E1.
5. Type Price & press Tab to activate cell F1.
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 Center the Column Labels
  To align the column labels, to right, left and center, use the Formatting toolbar.

1. Select the columns from A1 to E1, by draging the mouse from A1 
without releasing until the cursor is in E1. Release the click.

2. To align it in center, click Align Center Horizontally icon on the 
Formatting toolbar.

  You can also Change the Appearance the font by:
1. Select the cells, and click the Font Style icons(Bold, Italic, 

Underline) and click Font Color and Background Color to apply to 
the selected cells, from the Formatting toolbar.

             Adding an Additional Column
1. Select a column where you want to insert a new column. For instance, 

to insert Date column next to the Serial no. column, Select column 
B(Item Name) where the selected column turns black. 

2. Go to Insert > Columns, then the columns will shift to right.
3. Select the new Date column B and and type Date and press Enter.
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Border and Shading

Borders are used to separate data, mark certain cells and also draw the attention of the user.
There are two ways to select a block of cells:

1. Click the cell A1 (from which you want to start the selection) 
and drag it till the last cell that you want to select and then 
release the cursor. For instance, click and move the cursor 
onto F9.

2. Click the cell A1(from which you want to start the selection), 
and press Shift key and at the same time, click F9.

           Add a Border

1. Click Format > Cells (Ctrl+1), or click on the Border icon in the 
Formatting toolbar, a Format Cells dialog box appears.

2. Select the Border tab, where you have options for Line Arrangement, 
Line Style, Shadow Style, Spacing to Contents, Colors etc.
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Formatting Column and Text
We can also change the formatting by selecting a cell or a column and click Format > Cells. 

1. To change the centering and orientation , select the Alignment tab.
2. To change the font format, select Font tab.
3. To change the font's effect, colors etc, select Font Effect 

Hide or Show a Column
Columns can be hidden and it will not appear in the printout. At the top of the column, a 
missing letter tells which column is hidden. For instance, if you see column A followed by 
column C, then it means that column B is hidden. 

■ To Hide a column:  Click Format > Column > Hide.
■ To Show a hidden column: Select the column on both side of the 

hidden column, for instance if column B is hidden, then select Column 
A & Column C, so that both columns are highlighted and click Format 
> Show, which will show Column B. 
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Charting Data

A Chart is a group of related facts, usually presented in the form of diagram, table, graph or 
other visually organized model. It's also used to present and display information or 
instruction. 

1. Select Column A and B.
2. Then Click the Insert Chart icon on the Function Toolbar or click Insert > 

Chart, the AutoFormat Chart appears.
3. There you select a -New Sheet- from the drop-down box and click Next.

4. There you will find different types of chart. Choose the Column chart and click 
Next.
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5. Select Normal and by default, Y axis is already checked. Then click Next.

6. Name the Chart Title by replacing the 'Main Title' in it and also enable both X 
and Y axis titles. For instance, Admission Report.
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7. Then click Create and you will see a chart in your worksheet. To resize the 
chart, click and drag the little boxes in the corners until you like the 
proportions.

8. And to change the appearance of the chart, to look them better and more 
appealing, double-click on the chart and click Format > Chart Type, a 
Chart Type dialog box appears.

9. Choose the Chart category as 2D and set the Resolution. Select Lines in the 
Chart type and keep the Variant as Normal  and click OK.
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 To customize the fill color, background color, fills pattern etc, click Format > Chart Wall or 
Right-click on the chart, a Chart Wall dialog box appears. The chart wall have three tabs 
namely, Lines, Area and Transparency.

➢ Area : The Area tab allows you to change the background color, fill patterns, select 
bitmaps, choose a picture to use as background etc.
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➢ Lines : It's used to manipulate the lines by changing the line styles, color, specifying 

an icon as a marker, changing the line width etc.

➢ Transparency : It's used to make the background or the fill color transparent with 
different types of gradients.
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Print a Spreadsheet

To print out a spreadsheet, first you need to see what calc is going to print, by using the 
Page Preview Toolbar.

1. Use the buttons on the left of the spreadsheet, to bring up the Checking 
worksheet.

2. To preview the spreadsheet that you want to print, Go to File > Page 
Preview. The Page Preview toolbar appears.

3. The four book icons with arrows, on the left of the Preview toolbar will let 
you view each page that would go to the printer. These icons are:

■ The first book icon on the Page Preview toolbar, is the 
Previous Page.

■ The second book icon on the Page Preview toolbar, is the 
Next Page.

■ The third book icon  on the Page Preview toolbar, is the 
First Page.

■ The last book icon  on the Page Preview toolbar, is the Last 
Page.
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4.  Then Close Preview.

Headers and Footers

All the spreadsheets which is to be printed will have Headers which displays the Name of the 
Sheet, and Footer which shows the Page number. You can either turn them off or edit them 
by:

1. Go to Format > Page, a “Page Style:Default” dialog box appears.

2. Click the Header tab, to turn them off by unchecking the Header Check Box, or 
also can edit it, by clicking Edit.

3. You will see that the Header and Footers are broken further into three sections, in 
which you can edit, by using any of the auto-format buttons below the three boxes 
or type your own header.
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4. The Sheet tab gives you the capability to control the way Calc determines the page 
order and what features to print or scale, while other remaining tabs are self-
explanatory.

5. Then click Ok. And if you don't want the header to appear in your printed sheet, you 
can simply Uncheck the Header box. The same applies to Footers also.

Note : Removing of header and footer will change the size of the chart size, so you may 
have to resize it.
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Printing Range

Calc gives you the ability to define the Print Ranges, if you don't want to print the whole 
worksheet by:

1. Open the Worksheet or bring up the Checking worksheet.
2. Select A3:D8.

3. Then click Format > Print Ranges > Define, and open the Print Preview again.

4.  Finally, go to the File > Print and a Print dialog box appears.
5.  On the bottom left, click the Pages radio button.
6. Then type the Page Number of the worksheet.
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To Enable Dzongkha in Calc

The Calc can also be enabled in Dzongkha for computing & calculating in Dzongkha and to 
set up this, follow the steps:

1. Select entire document by hitting Ctrl + A.      
2. Click Format > Cells.
3. Select Dzongkha language in the Number tab.

4. Choose -  in the Format drop-down list.
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OpenOffice.org Impress

OpenOffice.org impress is a replacement for Microsoft Power point for creating presentation 
in Debian Linux. It offers more than just drawing and graphics, like to form a slide show, 
animate elements on the slides and applying special effects to the slides.
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How to create a basic presentation

I. Go to File > Wizard > Presentation, which opens a Wizard Presentation and click 
Next or open a new empty document (File > New > Presentation)  by first turning 
off the wizard (Tools > Options > Openoffice.org impress > General).

II. Open an existing document alternatively, that has been modified and saved under 
different name or 

III. Choose a Template from Template and Document Dialogue. or press Shift + Ctrl 
+ N to open this dialogue or click File > New > Template and Documents.
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How to create a wizard presentation

I. Go to File > New > Presentation, it gives choice to open an empty presentation, 
From Template or an existing presentation. To use all templates available, click From 
Template. 

II. Select a template example and click Next.
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III. Select a Slide Design ,and also select Output Medium, and the dimensions, 
margins and orientation of presentation will depend on these selections. And click 
Next.

IV. Select Slide Effects (“Cross-Fade from Left”), and Speed(“Medium”).

V. Select Automatic as Presentation Type, it will run the presentation with fixed time 
lapses, until Escape key is pressed. By default, Presentation Type runs the 
presentation from beginning to end with manual slide transition (by mouse click). 
Users can also fix the parameters:

● Duration of Page---> Duration of each slides shown before the next one appears.
●  Duration of Box----> Determine the duration at which the pause will be at the end 

of the presentation, before it starts again. 
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Enabling of Show Logo will display the logo “Created with openoffice.org” on the 
pause page. Click Next.
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VI. Enter the text for the presentation and click Next.

VII.This final presentation determines the no. of slides and if you want to remove some 
slides, just click “Page” icon, indicating  that particular slide is discarded.

VIII.Click “+” sign in front of a slide to show headings from the first outline level.
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IX. Click Create Summary checkbox to create additional slides of all previous 
presentation.

X. Click Create to create presentation,  then edit, save and run or print the presentation.

XI. Press Ctrl + F2 or click Presentation icon on the main toolbar to start the presentation.
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Slides Transition, Effects and Animation
 The Easy slide transition and animated objects grabs the audience attention and the best 
way to do is assign slide view by selecting View > Slide Show or F5, for Automatic slide 
transition. 
Click a button on all slides, to preview selected effects.

How to Draw an Object
In impress, one can even draw objects and insert pictures as you like, by going to View menu 
and select Toolbars > Drawing, which will display the drawing tools.
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Effects for Objects
There are various effects for objects like rolling presentation from left side, slowing drawing 
the text on the screen etc by customizing the Slide show.

Slide Presentation
It shows the slides in sequence for presentation from beginning to end. Click Slide Show 
icon on main toolbar or press Ctrl + F2.

I. Go to Tools > Options > OpenOffice.org impress > General.
II. Check the “Always with current slide” box.

III. To hide or show the slides, go to View > Master View > Slides View and select 
either Slide Show > Show/Hide Slide. The slide which is not meant to be displayed 
will be highlighted gray.

IV. To include the slide again, choose Slide Show > Show / Hide slide. 
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Another elegant way to keep individual slides hidden in some presentation, select 
Presentation > Slide Show.

1. Click Slide Show > Custom Slide Shows dialogue.
2. Click New, to enter name for presentation,  select custom slide show presentation 

and click  button with arrow pointing to the right.
3. The slide will be shown in the right field.
4. Rearrange order of slides in the right field by Drag & Drop.
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Printing Slides

Click Print File Directly icon on standard toolbar or go to File > Print or simply press Ctrl 
+ P.

The Print Dialog have options to print the entire presentation, certain slides, current 
selection, specifying no. of copies to print, how they should be collated.
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Openoffice.org Base

Openoffice.org Base is the database application of openoffice.org, similar to Microsoft Access. 
It allows the users to create and modify tables, forms, reports, queries and also manipulate 
databases to provide easy access for end-users. Base also offers a choice of using Wizards, 
Design Views to produce impressive report from your data.
To create a database, go to Application > Openoffice.org Base. A Database Wizard dialog 
box pops out which enable you to create a new database, open an existing database or 
connect to a database stored in the server. Select Save and Proceed button to proceed with 
the creation of a new database. 
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The screenshot of the Main Database screen.

Create a Database
To create a database or open an existing database, Go to Application > Openoffice.org 
Base, a Database wizard dialog box appears in which you have options to Create a new 
database or Open an Existing Database.

To create a Table:
1. Click on Tables button and select Use Wizard to Create to create a new 

database table and click Next.
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2. In the Select Field screen, you can either select the category of database that you 
want to create(Bussiness or Personal), for instance click Personal category to 
create a CD-Collection database.

3. Select the fields that you want to include in your table and click Next.

4. Then Set Types & Format screen appears in which you give field information like 
Field Name, Type, Value, Length etc and click Next.
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5. Primary key identifies each record in the database table and also ease the linking 
of information in separate tables.That's why it is recommended to have a primary 
key in every table. This can be done in the Set Primary Key screen, where you will 
will Create a Primary Key and click Next.

6. Now, you can name the table(eg.CD-Collection) that you have created.
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7. Once the entering of data is completed, Close the table.

To Create a Form:
Forms are used in an office or production environment to enter data nicely and quickly by 
using tab key or a mouse. It's also nice to enter data, queries and also lets you find and 
group data.

1. Select Form and click on the Use Wizard to Create Form.
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2. In the Form Wizard dialog box, click Field Selection button to select the fields you 
want to include in the table and bypass the Subform option by clicking Next.

3. You can Arrange Controls by selecting Columnar-Labels left button and click 
Next.
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4. Bypass Set Data Entry screen, and click Next to open Apply Styles screen. Use 
Beige styles with 3D and click Next.

5. Set the Name of the Form(eg. CD-Collection) in the Set Name screen.
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To Create a Report:
A Report is a formatted and organized presentation of data. In debian Linux, we have 
Openoffice.org Base to enable you to design and generate reports.

1. Click on the Report button and select Use Wizard to Create a Report.

2. Then in the Field Selection screen, select the fields you want in a report and click 
Next.
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3. Click Next to bypass the Labeling fields and in the Grouping screen, choose ID 
and Purchase Price fields, click Next.

4. In the Sorting option, select sort by ID, and click Next.
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5. To choose a layout of a report from Choose Layout screen, and set the Data 
Layout(eg. Outline, indented-Red & Blue) and for Header & Footer's Layout, keep 
(eg. Worldmap). Then click Next.

6. Select Static Report in the Create Report screen and click Finish.
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To Build a Query:
Queries are used for viewing, sorting and filtering data. It's easy to do a query.

1. Click the Queries button on the Main Database screen and select Use Wizard to 
Create Query, then click Next to open a Wizard Query dialog box.

2. Select the fields for your query form the Field Selection screen and click Next.
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3. In the Sorting Order screen, you can sort the data in an ascending order (eg. CD-
Collection.collectionID, CD-Collection.Artist, CD-Collection.AlbumTitle and CD-
Collection.PurchasePrice)  and click Next.

4. Bypass the Search Condition, Detail or Summary screen and Aliases screen by 
clicking Next, and Click Finish on the Overview screen.
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OpenOffice.org Draw
 Openoffice.org Draw is a drawing application which makes our creative work easier and 
more entertaining by adding, drawing, editing, and aligning objects; incorporating textures 
and work with colors and textures. We can also use it to draw complex shapes such as 
ellipse, a circle or a circle section. 

The three command bars available are:
1. The Menu bar
2. The Function bar
3. The Object bar

The Menu bar lists the menus available in the Draw Menu bar.

The Function bar displays the icons to access functions like copy, paste, cut, save, open and 
other openoffice.org common tasks.
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The Object bar contains some specific drawing tools which are used to modify the 
appearance of objects like styles, colors, thickness etc when it's selected.

The Main toolbar located at the bottom of the page will consist of tools to draw. 

And to activate the specific tool, click on the icon which is of toggle type. Then drag the 
mouse after selecting a tool and release it at any desired position. Light blue is the default fill 
color and to change the color of an object.

1. Select Format > Area in the Menu bar, an Area dialog box appears in 
which you choose the color you want to use.

2. Then right-click on the selected object and select Area, from which you set 
the color you want to apply to that selected object.

To change the line attribute:

1. Go to Format > Line, and choose the attribute of line that you want to 
change.

2. Right-click on the selected object to display it's context menu, and 
choose Line.

3. Now, select the color and style you prefer from the'Line Style' & 'Line 
color' drop down list box.

Likewise, we can also change the size and position of an object by passing the cursor over a 
green square. When cursor is on that green rectangle, it will transform into a line with little 
arrows at the edges which shows you the direction to resize the object. While resizing, you 
can also change the width and height at the same time.
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